Looking at the source, it looks like there's only one line that calls jQuery on line 37 (and I don't think it should be using the short calling convention without a wrapper -- if you rename jQuery to '_' or something else it won't work):
else if($.isNumeric(arg)
There's no native JavaScript equivalent to it if I recall correctly, but there's a bunch of alternatives to it as well.
It should be easy enough to extract out the logic and repackage it. Maybe I'll fork it tomorrow and do the changes myself.
No clue, but it's nice to have a namespace for it, rather than mucking up the global context with a simple utility method. Might be better off shimmying up to underscore (perhaps only if it's already detected, otherwise go global?), however there are lots of similar jquery 'plugins' of this nature..